Что такое findtheslide.com?

FindTheSlide.com - это сайт презентаций, докладов, шаблонов в формате PowerPoint.


Для правообладателей

Обратная связь

Email: Нажмите что бы посмотреть 

Яндекс.Метрика

Презентация, доклад на тему Рисуем супер-узоры

Презентация на тему Рисуем супер-узоры, из раздела: Разное. Эта презентация содержит 25 слайда(ов). Информативные слайды и изображения помогут Вам заинтересовать аудиторию. Скачать конспект-презентацию на данную тему можно внизу страницы, поделившись ссылкой с помощью социальных кнопок. Также можно добавить наш сайт презентаций в закладки! Презентации взяты из открытого доступа или загружены их авторами, администрация сайта не отвечает за достоверность информации в них. Все права принадлежат авторам презентаций.

Рисуем Супер-УзорыПроцедуры с параметрами ПараметрПараметр - это величина, которая может принимать различные значения и описывает какие-либо характеристики объектов. В Лого знак «:» перед именем параметра обязателен и показывает, что мы ********************************************это кв :дпоповтори 4[ вп :д пр 90]конец********************************************это тр :дпоповтори 3[вп :д пр 120]конец******************************************** Вызов процедурыДля того, чтобы черепашка нарисовала нужные фигуры, при вызове процедур необходимо Упражнение 1 Нарисовать картинку с помощью созданной вами процедуры с параметром Создайте кнопку на своем проекте с помощью инструмента   . Для Аналогичную кнопку сделайте для похожего узора из треугольников Ваш результат Пример применения  процедур с параметрами Пример программы Команда «КРАСЬ» Рисуем закрашенные квадратыэто кв :д :ц	заголовок с определением двух параметров (длина стороны Упражнение 2 С помощью процедур для закрашенного квадрата и треугольника составьте правильные многоугольникиМногоугольник называется правильным, если все его стороны и углы равны.Для того, правильный шестиугольникУгол поворота черепахи для него равен: 360/6=60. Его можно нарисовать такой произвольный правильный многоугольникк – количество сторон, д –длину стороны, ц –цвет пера Вызов процедурыесли нужно нарисовать пятиугольник с длиной стороны 30 шагов фиолетового цвета, Основные ошибкимн 30 5 115	- параметры переставлены местами;мн :к :д :ц - Упражнение 4 Создайте в проекте кнопки, которые рисуют шестиугольник, восьмиугольник и 36 Случайный выбор цветаПусть мы хотим случайно выбрать цвет рисования. Если посмотреть на Не забудь! Чтобы черепашка правильно воспринимала команды, не забудьте вводить пробелы впереди Упражнение 4 Создайте процедуру рисования случайного закрашенного многоугольника случайным цветом. То Упражнение 5 Целью этого задания будет изображение на экране снегопада. Для Результат
Слайды презентации

Слайд 1 Рисуем Супер-Узоры
Процедуры с параметрами

Рисуем Супер-УзорыПроцедуры с параметрами

Слайд 2 Параметр
Параметр - это величина, которая может

ПараметрПараметр - это величина, которая может принимать различные значения и описывает какие-либо характеристики объектов. принимать различные значения и описывает какие-либо характеристики объектов.


Слайд 3
В Лого знак «:» перед именем

В Лого знак «:» перед именем параметра обязателен и показывает, что параметра обязателен и показывает, что мы имеем дело со значением параметра, а не с его именем. При этом не стоит забывать, что между «:» и именем параметра пробела быть не должно.

Слайд 4
********************************************
это кв :д
по
повтори 4[ вп :д

********************************************это кв :дпоповтори 4[ вп :д пр 90]конец********************************************это тр :дпоповтори 3[вп :д пр 120]конец******************************************** пр 90]
конец
********************************************
это тр :д
по
повтори 3[вп :д пр 120]
конец
********************************************


Слайд 5 Вызов процедуры
Для того, чтобы черепашка нарисовала

Вызов процедурыДля того, чтобы черепашка нарисовала нужные фигуры, при вызове процедур нужные фигуры, при вызове процедур необходимо указать конкретные значение параметра. Например, для получения квадрата со стороной 100 шагов надо набрать в поле команд строку:
 
кв 100


Слайд 6 Упражнение 1
Нарисовать картинку с помощью созданной

Упражнение 1 Нарисовать картинку с помощью созданной вами процедуры с вами процедуры с параметром для рисования квадратов.
Используйте команды нц и нрп для задания цвета и толщины линии.

Слайд 7
Создайте кнопку на своем проекте с

Создайте кнопку на своем проекте с помощью инструмента   . помощью инструмента . Для этого выберите этот инструмент и растяните на проекте прямоугольник, определяющий размер и положение будущей кнопки. Откройте диалоговое окно кнопки с помощью инструмента (нажмите на глаз, а затем на кнопку) и введите в окно команд название созданной вами процедуры для рисования узора. После этого подтвердите ввод, нажав кнопку ОК.


Слайд 8
Аналогичную кнопку сделайте для похожего узора

Аналогичную кнопку сделайте для похожего узора из треугольников из треугольников

Слайд 9 Ваш результат

Ваш результат

Слайд 10 Пример применения процедур с параметрами

Пример применения  процедур с параметрами

Слайд 11 Пример программы

Пример программы

Слайд 12 Команда «КРАСЬ»

Команда «КРАСЬ»

Слайд 13 Рисуем закрашенные квадраты
это кв :д :ц заголовок

Рисуем закрашенные квадратыэто кв :д :ц	заголовок с определением двух параметров (длина с определением двух параметров (длина стороны и цвет) нц :ц смена цвета пера черепашки по повтори 4 [вп :д пр 90] рисование квадрата со стороной :д
пп вп 2 пр 90 вп 2 переход черепашки с поднятым пером внутрь квадрата
крась закраска внутренней области квадрата
нд 2 лв 90 нд 2 обратный переход в угол квадрата
конец окончание процедуры
 


Слайд 14 Упражнение 2
С помощью процедур для закрашенного

Упражнение 2 С помощью процедур для закрашенного квадрата и треугольника квадрата и треугольника составьте процедуру для рисования домика. Вызов этой процедуры вставьте в кнопку. Саму процедуру назовите ДОМ. Размеры домика – произвольные.


Слайд 15 правильные многоугольники
Многоугольник называется правильным, если все

правильные многоугольникиМногоугольник называется правильным, если все его стороны и углы равны.Для его стороны и углы равны.
Для того, чтобы написать соответствующую процедуру, следует заметить, что угол поворота черепашки для правильной фигуры можно получить по формуле:
угол = 360 / количество сторон


Слайд 16 правильный шестиугольник
Угол поворота черепахи для него

правильный шестиугольникУгол поворота черепахи для него равен: 360/6=60. Его можно нарисовать равен: 360/6=60. Его можно нарисовать такой командой:

повтори 6[вп 50 пр 60]


Слайд 17 произвольный правильный многоугольник
к – количество сторон,

произвольный правильный многоугольникк – количество сторон, д –длину стороны, ц –цвет
д –длину стороны,
ц –цвет пера черепашки.
Тогда процедура будет выглядеть следующим образом:
 
это мн :к :д :ц
нц :к
по
повтори :к[вп :д пр 360 / :к]
конец


Слайд 18 Вызов процедуры
если нужно нарисовать пятиугольник с

Вызов процедурыесли нужно нарисовать пятиугольник с длиной стороны 30 шагов фиолетового длиной стороны 30 шагов фиолетового цвета, следует использовать такую команду:

мн 5 30 115


Слайд 19 Основные ошибки

мн 30 5 115 - параметры

Основные ошибкимн 30 5 115	- параметры переставлены местами;мн :к :д :ц переставлены местами;
мн :к :д :ц - вместо числовых значений указаны имена параметров;
это мн 5 30 115 - помимо названия процедуры указано слово “это”.

Слайд 20 Упражнение 4
Создайте в проекте кнопки, которые

Упражнение 4 Создайте в проекте кнопки, которые рисуют шестиугольник, восьмиугольник и рисуют шестиугольник, восьмиугольник и 36 угольник с помощью созданной вами процедуры рисования многоугольника.
Как надо изменять длину стороны, чтобы многоугольник поместился на листе?
 
 


Слайд 21 Случайный выбор цвета
Пусть мы хотим случайно

Случайный выбор цветаПусть мы хотим случайно выбрать цвет рисования. Если посмотреть выбрать цвет рисования.
Если посмотреть на номера цветов в графическом редакторе, то можно заметить, что их номера меняются от5 (серый) до 135 (алый) с шагом 10.
Это значит, что самое маленькое значение цвета для нас будет 5.
Чтобы получить все остальные цвета, надо умножить на 10 некую случайную величину со значениями от 0 до 13 и прибавить ее к 5. В итоге:
нц 5 + 10 * сл 13


Слайд 22 Не забудь!
Чтобы черепашка правильно воспринимала

Не забудь! Чтобы черепашка правильно воспринимала команды, не забудьте вводить пробелы команды, не забудьте вводить пробелы впереди и после знаков арифметических операций - + (сложить) и * (умножить).


Слайд 23 Упражнение 4
Создайте процедуру рисования случайного закрашенного

Упражнение 4 Создайте процедуру рисования случайного закрашенного многоугольника случайным цветом. многоугольника случайным цветом. То есть с помощью датчика случайных величин укажите в качестве параметров при вызове процедуры многоугольника случайное значение цвета и количества сторон многоугольника. Создайте кнопку вызова процедуры с такими параметрами.

Слайд 24 Упражнение 5
Целью этого задания будет изображение

Упражнение 5 Целью этого задания будет изображение на экране снегопада. на экране снегопада. Для цвета, размера и количества лучей у снежинок примените случайные величины.
О задании цвета мы уже говорили выше. Длина лучей снежинки не должна быть слишком большой. Ограничим ее 40 шагами черепахи. В то же время, слишком маленькую снежинку можно принять за точку, поэтому пусть длина луча будет не меньше 10 шагов. Выражение для длины : 10 + сл 30 .
Количество лучей у снежинки тоже не может быть слишком маленьким. Снежинки менее чем с 4 лучами не очень красивые. Пусть количество лучей будет от 5 до 15. Выражение для этой величины: 5 + сл 10.
Прежде чем рисовать снег, составьте процедуру рисования одной снежинки по аналогии с процедурой многоугольника. Назовите ее снежинка. Используйте три параметра : к - количество лучей, д - длина луча, ц - цвет снежинки.

Слайд 25 Результат

Результат